Internet outage

Incident Report for IgLou Internet Services

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 10, 2026 - 09:33 EDT

Identified

We have identified a potential failure in one of our core edge routers and have moved to redundant hardware. Service appears to be restored but are continuing to investigate.
Posted Mar 10, 2026 - 07:35 EDT

Investigating

We are aware of a loss of Internet connectivity for certain colocation, email and hosting customers, and are investigating the cause.
Posted Mar 10, 2026 - 06:42 EDT
This incident affects: Network Connectivity, Server Colocation, Website & Email Hosting, and DNS Services.