Outage in Southern Louisville KY
Incident Report for IgLou Internet Services
Resolved
This incident has been resolved.
Posted Dec 12, 2019 - 16:41 EST
Identified
There is a known outage affecting customers in the Hillview, Okolona, and surrounding areas in southern Louisville KY. If you live in this area and your Internet service is out or running very slow, you are likely affected by this outage. The telephone company is aware of the outage though we do not yet have an ETA for repair.
Posted Dec 12, 2019 - 08:57 EST
This incident affected: Internet Access Services.