Internet outage in eastern Louisville
Incident Report for IgLou Internet Services
Resolved
The outage has been cleared and service restored. If you were affected by this outage and still do not have Internet access, please call IgLou technical support at 502-966-3848.
Posted Nov 18, 2020 - 11:24 EST
Update
The outage is still ongoing but AT&T has not yet provided a final ETA for repair. We will continue to provide updates as we receive new information.
Posted Nov 17, 2020 - 12:19 EST
Identified
There is a known outage affecting a number of Internet customers in Eastern Louisville around the Gene Snyder and Interstate 71, including the Crestwood area. If you live in this area and your Internet service is out or running slow you are most likely affected by this outage. The telephone company is aware of the outage though we do not yet have an ETA for repair.
Posted Nov 16, 2020 - 17:30 EST
This incident affected: Internet Access Services.