Yahoo email delivery issues
Incident Report for IgLou Internet Services
Resolved
Yahoo has indicated the email issue should now be resolved.
Posted Nov 10, 2022 - 11:44 EST
Monitoring
Yahoo responded that they have resolved the issue for some of our customers, but we are still waiting on final resolution. We have reached out to them again to try and resolve the issue for those still impacted.
Posted Nov 07, 2022 - 15:58 EST
Investigating
Email deliveries to Yahoo-owned domain names, including Yahoo.com, AOL and Ymail, are being incorrectly rejected for a number of our cPanel hosting customers. This issue started on 11/3/22 and is still ongoing. Multiple workarounds have been attempted but Yahoo's servers continue to reject emails despite our efforts. We have reached out to Yahoo email postmaster and customer care with no response, and will continue to try and do so until resolved.
Posted Nov 04, 2022 - 12:47 EDT
This incident affected: Website & Email Hosting.