Website and email hosting service interruption
Incident Report for IgLou Internet Services
Resolved
The outage was caused by a critical switch fault that affected multiple servers. The issue was quickly identified, fail over procedures implemented and service has been restored.
Posted Jul 31, 2024 - 11:05 EDT
Investigating
We are aware of an outage affecting some website and email hosting customers. We are investigating the cause of the issue now.
Posted Jul 31, 2024 - 10:01 EDT
This incident affected: Website & Email Hosting.