Outage in southern Louisville
Incident Report for IgLou Internet Services
Resolved
AT&T has reported the outage cleared and all services are now restored. If you are still experiencing slow speeds, please IgLou contact support at 502-966-3848 or online through our customer portal at http://www.iglou.com/accountmanager
Posted Feb 05, 2021 - 17:01 EST
Update
AT&T is reporting that the outage is still ongoing and that there is not yet an ETA for repair. We will continue to update as we receive new information.
Posted Feb 05, 2021 - 09:52 EST
Identified
A known outage has been identified in southern Louisville, near Preston Highway and the Gene Snyder (I265). Affected customers are reporting very slow speeds. If you are experiencing slow speeds and live in this area you are likely affected by this outage. We have not yet received an ETA for repair from the telephone company but will update once we receive more detailed information.
Posted Feb 04, 2021 - 16:54 EST
This incident affected: Internet Access Services.