Outage in Dayton, OH
Incident Report for IgLou Internet Services
Resolved
We have received no further reports of trouble in the Dayton area, and closing this outage notification.
Posted Nov 22, 2019 - 10:55 EST
Identified
There is a known outage affecting a number of Internet customers in the Dayton and surrounding areas in Ohio. If you live in this area and your Internet service is out or running very slow, you are most likely affected by this outage.

The telephone company is aware of the problem and working to resolve the issue, though we have not been given a cause or ETA for repair.
Posted Nov 21, 2019 - 17:16 EST
This incident affected: Internet Access Services.