Partial Internet Outage
Incident Report for IgLou Internet Services
Resolved
This incident has been resolved.
Posted Sep 20, 2021 - 11:28 EDT
Identified
There is a known outage affecting a number of Internet customers in the Highlands, Douglas Blvd, Bonnycastle and surrounding areas in Louisville. If you live in this areas and your Internet service is out or running very slow, you are most likely affected by this outage.
The telephone company is aware of the problem though we do not have an ETA for repair. n normal hold times.
Posted Sep 17, 2021 - 13:53 EDT
This incident affected: Internet Access Services.