Widespread Internet service outages
Incident Report for IgLou Internet Services
Resolved
This incident has been resolved.
Posted Mar 08, 2023 - 12:39 EST
Identified
Due to the high winds in Kentucky, Indiana and Tennessee today, there are widespread power outages due to downed limbs and trees. This is also causing outages for a number of our home and business Internet service customers. If your power is on but your Internet service isn't working, keep in mind that telephone company equipment several blocks away without power can cause an outage over a wide area, even if some of those areas still have power.

Be sure to wait until your power is restored before troubleshooting your Internet service, and to wait at least 30 minutes for service to come back online before reporting trouble.
Posted Mar 03, 2023 - 18:32 EST
This incident affected: Internet Access Services.