IgLou webmail and website unavailable
Incident Report for IgLou Internet Services
Resolved
This incident has been resolved.
Posted Apr 03, 2023 - 08:56 EDT
Monitoring
Service has been restored and we are now monitoring.
Posted Apr 02, 2023 - 09:42 EDT
Identified
There is an issue with the physical server running IgLou's website and webmail services. Technicians have identified the problem and are working to resolve the issue at this time.
Posted Apr 02, 2023 - 09:31 EDT