Email spam filtering outage
Incident Report for IgLou Internet Services
Resolved
The SpamExperts filtering service is reporting that the issue affecting email delivery yesterday on 9/15 has been resolved and mail should now be flowing normally.
Posted Sep 16, 2020 - 10:25 EDT
Identified
IgLou has been notified of an outage that is affecting the third-party commercial spam filtering service (SpamExperts) that some of our email hosting customers use. The result of this outage is emails are delayed or not being received. We have been told that no email has been lost, just delayed in final delivery. Once we receive confirmation the outage is cleared we will update the status here. NOTE: This does not affect @iglou.com email accounts, only customers with registered domain names.
Posted Sep 15, 2020 - 15:36 EDT
This incident affected: Website & Email Hosting.